TWF Racing - Forums

Collapse
No announcement yet.

TWF Racing - Forums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What Is This Green 2 Wire Connector For In My Gen 1 Wiring Harness?

    So Im replacing my old harness with a spare because my old one has a few issues and I cannot figure out what this green connector is for. The previous owner cut the leads to whatever it connected to and spliced them together. The problem is I cant find this connector anywhere on my old harness or my bike, so Im totally confused here. This spare harness is identical in every other way to my old harness so im pretty certain its for a gen 1 SV650 naked model just like mine. However I did bypass a couple safety switches on my old harness becaise they were faulty, but I dont see where or how I could have removed this green connector and its wiring from my ild harness completely. Thanks in advance.





  • #2

    Comment


    • #3
      I'm going to go out on a limb and say that is your side stand switch. Location seems right (by battery box lid), the fact it's two wire. I didn't look too hard at what you have, but if you have a green wire and a black/white tracer. It's a Clymer diagram, so it looks darker than the green running to the taillight connector.

      Comment


      • #4
        Thanks man. Thats what I kept coming back to, but Im really confused as to why the connector on the wiring harness side isnt there on my old harness. Im pretty certain I bypassed it on my old harness, but I hoghly doubt I would have removed both connectors and I definitely dodnt tear into my harness enough to delete the wiring completely from the harness. Im wondering if the connectors changed between years within the first gens. I know there were a couple differences in wiring harnesses between 1999 and 2002, or is that incorrect? Its really confusing to me that there is no 2 wire green connector to be found on my old harness.

        Comment


        • #5
          Probably cut off and splice wires together on harness side. See if you can find wires wrapped in harness somewhere.

          Comment


          • #6
            Thanks Zoran. Ive been checking but its stillgot the stock wrap on it. The thing is the harness thats missing the green connector is my harness that ive had on the bike since I got it. I dont think I would have done that. Ill have to triple check. Is it the sidestand safety switch? I havent worked on my SV harness in quiet a while so Im really rusty where as you could tell me exactly what a connector is for just by looking at it. If its the sidestand switch then Im good. Im just scratching my head as to what this thing does lol. Thanks again, hefe.

            Comment


            • #7
              Yes, it is side stand

              Comment


              • #8
                Yep, you were 100% right. I wasnt looking hard enough. Kept digging and found where I deleted both sides of that connector, soldered, shrink wrapped and tucked away the 2 leads. That makes me feel better. It also got ke obsessing over the tape falling apart so I just got done unwrapping all of it, cleaning the entire harness in 6" sections and rewrapping it all. Looks muh much better now. Anyways thanks again for your guidance. Its really great that after all these years I can still come back to TWF and have you make me feel like a total idiot hahahaha. Cheers buddy. Next step, new 10awg leads for this old mosfet R/R. Ahhh, I remember when this was a pretty new mod for the SV.

                Comment

                Working...
                X